Sirius radio keeps updating

Rated 3.84/5 based on 836 customer reviews

They're going to try replacing the antenna this time. Maybe 10% of the time, when I start the vehicle receive "updating channels." Current channel comes thru loud and clear. I just got my new GLK350 4 weeks ago and have the same issue. I was traveling on business, and rented two different GLKs, both with Sirius, both for a week (different cities). Hopefully the antenna switch-out will do the trick. Sadly, I've already begun now the process of documenting this in such a way that I can have the dealer buy back the car under the lemon law if necessary. Really like the car otherwise, but I am a satellite radio addict, and can't live without that -- the way Benz does switching between stations (left-hand side controls on the steering wheel, press on a button immediately switches stations) was a huge factor in us getting the GLK over the Q5 or X3. Should I ask for the Comand unit to be switched out?Unfortunately, I drove into my parking garage before it quit.After 9 hours at work, I left the parking garage and it just stayed on the "Acquiring signal" for my 25 minute commute.We went through 30 minutes of troubleshooting and testing different ways of trying to solve this.He also tried turning on the demo signal and that didn't work either. But I never lose the preview channel so I am getting something. I'm expecting a call from one of their engineers tomorrow.Maybe 10% of the time, when I start the vehicle receive "updating channels." Current channel comes thru loud and clear. I don't blame your dealer as a replacement would result in the same problem. It happens on one of my older MB's all the time, never on the newer ones. I'm afraid since it is not consistent the dealer will not find and repair under warranty. But switching out the control unit didn't do the trick. I had thought that perhaps it was a bad wiring harness, but if you're having the problem, too, then that's unlikely (my thinking is that the wiring harness got nicked in installation). Dealer was able to reproduce the problem, and their diagnostics were showing that the signal was coming into the control unit, but that the control unit was saying it wasn't getting a signal. I was going to see if the antenna and wires were secure before taking back to dealer.But otherwise I'm locked out -- can't change presets or do anything else with satellite radio. I dunno -- if Mercedes is the only vehicle manufacturer that seems to have this problem with Sirius, that strikes me as a Mercedes problem. I'll let you know what happens once the antenna has been switched out. But switching out the control unit didn't do the trick. I had thought that perhaps it was a bad wiring harness, but if you're having the problem, too, then that's unlikely (my thinking is that the wiring harness got nicked in installation). I have owned my 2014 GLK for around 12 hours and on the second drive the SAT came up "Updating Channels" and never completed. Frankly, what I'm wondering is that perhaps this is ultimately a software issue. They replaced the antenna, and the problem was still present.

Standard dealer proedure would be to reboot the system - then put it outside to see if it accepts SIRIUS update - if it does not then the COMAND unit would be ordered in to replace your unit. I have owned probably 6 other cars with Sirius/XM and have had channel updates on rare occasion, but they would only take a few minutes to complete. So this is definitely an endemic issue to new 2014s. I don't know where the satellite module is, unfortunately. Furthermore, they contacted the national Mercedes people -- this problem is widespread all over the country. After 10 minutes, I lost all channels and saw "unsubscribed" flash on the screen.So I called the phone # on the screen, got the refresh, the screen said, "subscription updated, press any key to continue." Soon I was listening to music again. With a situation as specialized as yours, personally, I would contact their facebook page support. Cheers The only other thing I would suggest is sending a refresh signal but, it seems clear that something is mixed up on their end from the activation.Anyone have an idea of how to force a reset or do anything else?Mine went back to saying I was unsubscribed this morning , I called and tried to send a refresh, but it didn't get there before I arrived at work.

Leave a Reply